#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "["']+([^"']+)["']+|([^\s"']+)"
Local $sString = ""hello world" how are you?"
Local $sSubst = "+"\1" +\2*"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)