re = /["']+([^"']+)["']+|([^\s"']+)/
str = '"hello world" how are you?'
subst = '+"\\1" +\\2*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result