package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`["']+([^"']+)["']+|([^\s"']+)`)
var str = `"hello world" how are you?`
var substitution = "+"\1" +\2*"
fmt.Println(re.ReplaceAllString(str, substitution))
}