$re = '/["\']+([^"\']+)["\']+|([^\s"\']+)/';
$str = '"hello world" how are you?';
$subst = "+\"\1\" +\2*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;