import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\s)([ABCDEFG]|Am|Bm|Cm|Dm|Em|Gm)(?=\\s)";
final String string = " D A Bm\n"
+ "I could stay awake just to hear you breathing\n\n"
+ " G D Em\n"
+ "Watch you smile while you are sleeping while your far away\n\n"
+ "A\n"
+ "dreaming\n\n"
+ " D A Bm\n"
+ "I could spend my life in this sweet surrender\n\n"
+ " G D Em \n"
+ "I could stay lost in this moment forever\n\n\n"
+ " A G A\n"
+ "Every moment spent with you is a moment I treasure\n\n\n\n"
+ "Chorus:\n"
+ "D A\n\n"
+ " I don't want to close my eyes";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}