re = /(?<=\s)([ABCDEFG]|Am|Bm|Cm|Dm|Em|Gm)(?=\s)/m
str = ' D A Bm
I could stay awake just to hear you breathing
G D Em
Watch you smile while you are sleeping while your far away
A
dreaming
D A Bm
I could spend my life in this sweet surrender
G D Em
I could stay lost in this moment forever
A G A
Every moment spent with you is a moment I treasure
Chorus:
D A
I don\'t want to close my eyes'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end