# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\s)([ABCDEFG]|Am|Bm|Cm|Dm|Em|Gm)(?=\s)"
test_str = (" D A Bm\n"
"I could stay awake just to hear you breathing\n\n"
" G D Em\n"
"Watch you smile while you are sleeping while your far away\n\n"
"A\n"
"dreaming\n\n"
" D A Bm\n"
"I could spend my life in this sweet surrender\n\n"
" G D Em \n"
"I could stay lost in this moment forever\n\n\n"
" A G A\n"
"Every moment spent with you is a moment I treasure\n\n\n\n"
"Chorus:\n"
"D A\n\n"
" I don't want to close my eyes")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.