use strict;
my $str = ' D A Bm
I could stay awake just to hear you breathing
G D Em
Watch you smile while you are sleeping while your far away
A
dreaming
D A Bm
I could spend my life in this sweet surrender
G D Em
I could stay lost in this moment forever
A G A
Every moment spent with you is a moment I treasure
Chorus:
D A
I don\'t want to close my eyes';
my $regex = qr/(?<=\s)([ABCDEFG]|Am|Bm|Cm|Dm|Em|Gm)(?=\s)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}