using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"'^/str1/str2/[0-9a-f_]/:[0-9a-f_]/[0-9a-f_]/(.*)$'";
string input = @"/str1/str2/a/:b/c/test/test5";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}