// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)'^/str1/str2/[0-9a-f_]/:[0-9a-f_]/[0-9a-f_]/(.*)$'").unwrap();
let string = "/str1/str2/a/:b/c/test/test5";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}