const regex = new RegExp('\\'^/str1/str2/[0-9a-f_]/:[0-9a-f_]/[0-9a-f_]/(.*)$\\'', 'gm')
const str = `/str1/str2/a/:b/c/test/test5`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}