re = /'^\/str1\/str2\/[0-9a-f_]\/:[0-9a-f_]\/[0-9a-f_]\/(.*)$'/m
str = '/str1/str2/a/:b/c/test/test5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end