package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/(.*?)\/?$`)
var str = `/ff/
/ff`
var substitution = "/\1.php"
fmt.Println(re.ReplaceAllString(str, substitution))
}