$re = '/\/(.*?)\/?$/m';
$str = '/ff/
/ff';
$subst = "/\1.php";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;