use strict;
my $str = '/ff/
/ff';
my $regex = qr/\/(.*?)\/?$/mp;
my $subst = '/\\1.php';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";