#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^([0-9]{2})\.[ ]*([a-zA-Z]{1,6})\.[ ]+([0-9]{2}):([0-9]{2})[ -]*([a-zA-ZöäüÖÄÜß]+)[:]?"
Local $sString = "23. Apr. 06:47 - Name:"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")