// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^([0-9]{2})\.[ ]*([a-zA-Z]{1,6})\.[ ]+([0-9]{2}):([0-9]{2})[ -]*([a-zA-ZöäüÖÄÜß]+)[:]?").unwrap();
let string = "23. Apr. 06:47 - Name:";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}