const regex = /^([0-9]{2})\.[ ]*([a-zA-Z]{1,6})\.[ ]+([0-9]{2}):([0-9]{2})[ -]*([a-zA-ZöäüÖÄÜß]+)[:]?/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([0-9]{2})\\.[ ]*([a-zA-Z]{1,6})\\.[ ]+([0-9]{2}):([0-9]{2})[ -]*([a-zA-ZöäüÖÄÜß]+)[:]?', '')
const str = `23. Apr. 06:47 - Name:`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}