$re = '/^([0-9]{2})\.[ ]*([a-zA-Z]{1,6})\.[ ]+([0-9]{2}):([0-9]{2})[ -]*([a-zA-ZöäüÖÄÜß]+)[:]?/';
$str = '23. Apr. 06:47 - Name:';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);