using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(\d+)\s+(?:(\S+) )?)?([^(]+\([^)]*\))$";
string input = @"1234 ab$.5!c=:d6 efg(789)
1234 efg(567)
efg(567)
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}