const regex = /^(?:(\d+)\s+(?:(\S+) )?)?([^(]+\([^)]*\))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(\\d+)\\s+(?:(\\S+) )?)?([^(]+\\([^)]*\\))$', 'gm')
const str = `1234 ab\$.5!c=:d6 efg(789)
1234 efg(567)
efg(567)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}