$re = '/^(?:(\d+)\s+(?:(\S+) )?)?([^(]+\([^)]*\))$/m';
$str = '1234 ab$.5!c=:d6 efg(789)
1234 efg(567)
efg(567)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);