// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:(\d+)\s+(?:(\S+) )?)?([^(]+\([^)]*\))$").unwrap();
let string = "1234 ab$.5!c=:d6 efg(789)
1234 efg(567)
efg(567)
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}