$re = '/<a.*?href=\"(.+?.pdf\?min)\".*?>(.*?)<\/a>/s';
$str = '<table cellspacing="0" cellpadding="0" width="100%" border="0">
<tbody>
<tr>
<td width="25%"><a href="http://www.test.com/myfile.pdf?min" target="_blank">Menus 18 €</a></div></td>
<td width="25%"><a href="http://www.test.com/myfile.pdf?min" target="_blank">Menus 24 et 26 €</a></div></td>
<td width="25%"><a href="http://www.test.com/myfile.pdf?min" target="_blank">Menus 30 et 37 € </a></div></td>
<td width="25%"><a href="http://www.test.com/myfile.pdf?min">La Carte détaillée <br>
(Entrées - Viandes - Poissons)</a></td>
</tr>
</tbody>
</table>';
$subst = "ok";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;