using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[C][:]\\[A-Z+a-z ()0-9\\]{1,3}+[.]exe+$";
string input = @"C:\program files\*
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}