$re = '/^[C][:]\\\\[A-Z+a-z ()0-9\\\\]{1,3}+[.]exe+$/';
$str = 'C:\\program files\\*
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);