package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[C][:]\\[A-Z+a-z ()0-9\\]{1,3}+[.]exe+$`)
var str = `C:\program files\*
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}