const regex = /^[C][:]\\[A-Z+a-z ()0-9\\]{1,3}+[.]exe+$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[C][:]\\\\[A-Z+a-z ()0-9\\\\]{1,3}+[.]exe+$', '')
const str = `C:\\program files\\*
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}