using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<tag><%s:(?<name>[a-z]+)[^\/>]*(?:\/>|>[^<]*<\/%s:[^\/>]*>))$";
string input = @"<%s:tag />
<%s:tag></%s:tag>
<%s:tag>Test</%s:tag>
<%s:tag>http://www.google.com</%s:tag>
<%s:tag><a href=""http://google.com"">http://google.com</a></%s:tag>
<%s:tag href=""http://google.com"">http://google.com</%s:tag>
<%s:tag id=""1"">http://google.com</%s:tag>
<%s:tag id=""a slash (/) in here isnt allowed"">http://google.com</%s:tag>
<%s:tag id=""2"">everything but <tags/> are allowed</%s:tag>
<%s:link target=""1-1-1-1-1""><%s:media id=""123"" /></%s:link>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}