package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<tag><%s:(?<name>[a-z]+)[^\/>]*(?:\/>|>[^<]*<\/%s:[^\/>]*>))$`)
var str = `<%s:tag />
<%s:tag></%s:tag>
<%s:tag>Test</%s:tag>
<%s:tag>http://www.google.com</%s:tag>
<%s:tag><a href="http://google.com">http://google.com</a></%s:tag>
<%s:tag href="http://google.com">http://google.com</%s:tag>
<%s:tag id="1">http://google.com</%s:tag>
<%s:tag id="a slash (/) in here isnt allowed">http://google.com</%s:tag>
<%s:tag id="2">everything but <tags/> are allowed</%s:tag>
<%s:link target="1-1-1-1-1"><%s:media id="123" /></%s:link>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}