use strict;
my $str = '<%s:tag />
<%s:tag></%s:tag>
<%s:tag>Test</%s:tag>
<%s:tag>http://www.google.com</%s:tag>
<%s:tag><a href="http://google.com">http://google.com</a></%s:tag>
<%s:tag href="http://google.com">http://google.com</%s:tag>
<%s:tag id="1">http://google.com</%s:tag>
<%s:tag id="a slash (/) in here isnt allowed">http://google.com</%s:tag>
<%s:tag id="2">everything but <tags/> are allowed</%s:tag>
<%s:link target="1-1-1-1-1"><%s:media id="123" /></%s:link>';
my $regex = qr/^(?<tag><%s:(?<name>[a-z]+)[^\/>]*(?:\/>|>[^<]*<\/%s:[^\/>]*>))$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}