using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""username"": ""(?!Bot[12]"")([^""]+)"",(?:\s*""[^""]+"": (?:[^""]+|""[^""]*""),)*\s*""channel_id"": ""(\d+)""";
string input = @"""members"": [
{
""id"": ""0"",
""username"": ""User1"",
""discriminator"": ""0000"",
""avatar"": null,
""status"": ""online"",
""avatar_url"": ""https://cdn.discordapp.com/widget-avatars/..."",
""deaf"": false,
""mute"": false,
""self_deaf"": false,
""self_mute"": false,
""suppress"": false,
""channel_id"": ""42""
},
{
""id"": ""1"",
""username"": ""Bot1"",
""discriminator"": ""0000"",
""avatar"": null,
""status"": ""online"",
""avatar_url"": ""https://cdn.discordapp.com/widget-avatars/...""
},
{
""id"": ""2"",
""username"": ""Bot2"",
""discriminator"": ""0000"",
""avatar"": null,
""status"": ""online"",
""avatar_url"": ""https://cdn.discordapp.com/widget-avatars/..."",
""game"": {
""name"": ""music | /help""
},
""deaf"": false,
""mute"": false,
""self_deaf"": false,
""self_mute"": false,
""suppress"": false,
""channel_id"": ""17""
}
],
""presence_count"": 3
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}