import Foundation
let pattern = #""username": "(?!Bot[12]")([^"]+)",(?:\s*"[^"]+": (?:[^"]+|"[^"]*"),)*\s*"channel_id": "(\d+)""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
"members": [
{
"id": "0",
"username": "User1",
"discriminator": "0000",
"avatar": null,
"status": "online",
"avatar_url": "https://cdn.discordapp.com/widget-avatars/...",
"deaf": false,
"mute": false,
"self_deaf": false,
"self_mute": false,
"suppress": false,
"channel_id": "42"
},
{
"id": "1",
"username": "Bot1",
"discriminator": "0000",
"avatar": null,
"status": "online",
"avatar_url": "https://cdn.discordapp.com/widget-avatars/..."
},
{
"id": "2",
"username": "Bot2",
"discriminator": "0000",
"avatar": null,
"status": "online",
"avatar_url": "https://cdn.discordapp.com/widget-avatars/...",
"game": {
"name": "music | /help"
},
"deaf": false,
"mute": false,
"self_deaf": false,
"self_mute": false,
"suppress": false,
"channel_id": "17"
}
],
"presence_count": 3
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)