const regex = /"username": "(?!Bot[12]")([^"]+)",(?:\s*"[^"]+": (?:[^"]+|"[^"]*"),)*\s*"channel_id": "(\d+)"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"username": "(?!Bot[12]")([^"]+)",(?:\\s*"[^"]+": (?:[^"]+|"[^"]*"),)*\\s*"channel_id": "(\\d+)"', 'gm')
const str = `"members": [
{
"id": "0",
"username": "User1",
"discriminator": "0000",
"avatar": null,
"status": "online",
"avatar_url": "https://cdn.discordapp.com/widget-avatars/...",
"deaf": false,
"mute": false,
"self_deaf": false,
"self_mute": false,
"suppress": false,
"channel_id": "42"
},
{
"id": "1",
"username": "Bot1",
"discriminator": "0000",
"avatar": null,
"status": "online",
"avatar_url": "https://cdn.discordapp.com/widget-avatars/..."
},
{
"id": "2",
"username": "Bot2",
"discriminator": "0000",
"avatar": null,
"status": "online",
"avatar_url": "https://cdn.discordapp.com/widget-avatars/...",
"game": {
"name": "music | /help"
},
"deaf": false,
"mute": false,
"self_deaf": false,
"self_mute": false,
"suppress": false,
"channel_id": "17"
}
],
"presence_count": 3
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}