#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<span question_number="(\d+)">(.*?)<\/span>"
Local $sString = "<span question_number="54">often graces doorways tied into ropes called</span>" & @CRLF & _
"<span question_number="55">Allow retracting flags on deleted posts even if you can't view deleted posts</span>" & @CRLF & _
"<span question_number="56">Multiple accepted answer to a question?</span><span question_number="57">Post-edit by 3rd party editor created errors, and 3 out of 4 editors approved</span>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")