use strict;
my $str = '<span question_number="54">often graces doorways tied into ropes called</span>
<span question_number="55">Allow retracting flags on deleted posts even if you can\'t view deleted posts</span>
<span question_number="56">Multiple accepted answer to a question?</span><span question_number="57">Post-edit by 3rd party editor created errors, and 3 out of 4 editors approved</span>';
my $regex = qr/<span question_number="(\d+)">(.*?)<\/span>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}