# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<span question_number=\"(\d+)\">(.*?)<\/span>"
test_str = ("<span question_number=\"54\">often graces doorways tied into ropes called</span>\n"
"<span question_number=\"55\">Allow retracting flags on deleted posts even if you can't view deleted posts</span>\n"
"<span question_number=\"56\">Multiple accepted answer to a question?</span><span question_number=\"57\">Post-edit by 3rd party editor created errors, and 3 out of 4 editors approved</span>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.