#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^DT(\s+DT)*((\s+RB)+|(\s+JJ)+)(\s+NN)+$"
Local $sString = "DT NN IN NN" & @CRLF & _
"DT RB JJ NN" & @CRLF & _
"DT JJ JJ NN" & @CRLF & _
"DT RB RB NN NN" & @CRLF & _
"DT RB RB"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")