import re
regex = re.compile(r"^DT(\s+DT)*((\s+RB)+|(\s+JJ)+)(\s+NN)+$", flags=re.MULTILINE)
test_str = ("DT NN IN NN\n"
"DT RB JJ NN\n"
"DT JJ JJ NN\n"
"DT RB RB NN NN\n"
"DT RB RB")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")