const regex = new RegExp('^DT(\\s+DT)*((\\s+RB)+|(\\s+JJ)+)(\\s+NN)+$', 'gm')
const str = `DT NN IN NN
DT RB JJ NN
DT JJ JJ NN
DT RB RB NN NN
DT RB RB`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}