#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?=(?:(?:[^"][do_collapse"){2})*[^"]*$)))"
Local $sString = "[do_collapse id='dsds'] fewfw fewfw [/do_collapse] @user1 @user2 ignoreme" & @CRLF & _
"[header]frfw[/header]" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
":\)(?=(?:(?:[^"][do_collapse"){2})*[^"]*$)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")