const regex = /(?=(?:(?:[^"][do_collapse"){2})*[^"]*$)))/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=(?:(?:[^"][do_collapse"){2})*[^"]*$)))', '')
const str = `[do_collapse id='dsds'] fewfw fewfw [/do_collapse] @user1 @user2 ignoreme
[header]frfw[/header]
:\\)(?=(?:(?:[^"][do_collapse"){2})*[^"]*\$)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}