$re = '/(?=(?:(?:[^"][do_collapse"){2})*[^"]*$)))/';
$str = '[do_collapse id=\'dsds\'] fewfw fewfw [/do_collapse] @user1 @user2 ignoreme
[header]frfw[/header]
:\\)(?=(?:(?:[^"][do_collapse"){2})*[^"]*$)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);