using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=(?:(?:[^""][do_collapse""){2})*[^""]*$)))";
string input = @"[do_collapse id='dsds'] fewfw fewfw [/do_collapse] @user1 @user2 ignoreme
[header]frfw[/header]
:\)(?=(?:(?:[^""][do_collapse""){2})*[^""]*$)";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}