re = /\/issues\/([0-9]+)/m
str = 'https://xyz.abc.yahoo.com/issues/80483987/tasks/1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end