#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?iu)(?:https?:\/\/)?videos.francesoir.fr\/\?mediaId=(.*)"
Local $sString = "http://videos.francesoir.fr/?mediaId=d70ba1c2-30d7-4dba-bdfb-63b89a083d3f"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")