import re
regex = re.compile(r"(?:https?:\/\/)?videos.francesoir.fr\/\?mediaId=(.*)", flags=re.IGNORECASE | re.UNICODE)
test_str = "http://videos.francesoir.fr/?mediaId=d70ba1c2-30d7-4dba-bdfb-63b89a083d3f"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")