$re = '/(?:https?:\/\/)?videos.francesoir.fr\/\?mediaId=(.*)/iu';
$str = 'http://videos.francesoir.fr/?mediaId=d70ba1c2-30d7-4dba-bdfb-63b89a083d3f';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);