// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?iu)(?:https?:\/\/)?videos.francesoir.fr\/\?mediaId=(.*)").unwrap();
let string = "http://videos.francesoir.fr/?mediaId=d70ba1c2-30d7-4dba-bdfb-63b89a083d3f";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}