using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!0$)\d+(?:[,.][05])?$";
string input = @"0,5
0.5
0.7
0,9
1,0
1.0
1.4
1,4
1.5
0
0,0
0000.000
00000,00000";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}